WordPress y errores de PHP en pantalla…

Ocasionalmente, al instalar un theme o plugin de wordpress, podemos tener advertencias de php al visualizar la página.

Warning: implode() [function.implode]: Invalid arguments passed in

Este tipo de errores suelen ser ‘inofensivos’, debemos reparar el error, pero mientras lo hacemos podemos ocultar este mensaje de nuestros lectores añadiendo lo siguiente al final del archivo wp-config.php

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');

/** Estas lineas evitan que los mensajes de error de PHP salgan al presentar la página **/
error_reporting(0);
@ini_set(‘display_errors’, 0);

Es muy importante que estas líneas esten después de la llamada a wp-settings.php, de lo contrario los valores para error_reporting serán los que se tomen como válidos al presentar la página.

Saludos

Deja tu comentario

%d bloggers like this: